Heartbleed OpenSSL Vulnerability

Please read this article to get a better understanding of what the Heartbleed OpenSSL vulnerability is: http://www.troyhunt.com/2014/04/everything-you-need-to-know-about.html
OpenSSL is primarily used on Apache and nginx web server platforms, although there are some implementations for other platforms.  We use Microsoft IIS for a majority of our web servers which is not affected by this vulnerability.  Of the systems we have running Apache or nginx, those do not currently host secure websites.  In short this means that we are not using OpenSSL in any way that our customers can be affected by Heartbleed. 
Patches are currently being deployed to remedy this so that if any sites running on these platforms require the use of OpenSSL in the future, the vulnerability will have already been mitigated on our systems.